Android or iPhone?

In most regions, an Android 4.4 (or above) with a phone camera is required. In certain regions, an iPhone 5 or newer is allowed. This is all because the Amazon Flex app is only available in certain regions. You will know which device is needed for your region once you are asked to take the Amazon Flex eligibility survey.

 

Android requirements:

  • 4.4 or higher
  • phone camera with a flash
  • 2GB RAM or higher
  • SIM card
  • GPS

iPhone requirements:

  • iPhone 5 or newer
  • iOS 8 or higher
Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.